Gavelthief - Waste of time

Poster
Message
Australia Australia
ekrabappel
Kudos: 15
Joined: Jan 18, 2011
Gavelthief - Waste of time
18 Jan 2011
I downloaded the beta version of GavelThief about 9 months ago and it was pretty good until the beginning of 2011. I went to place a snipe but was informed "License has expired". I thought maybe new version was available but no. Even tried purchasing an account but was told user already exists. Well yeah, that's me you idiots. Tried emailing support and received e-mail with ticket number saying they will get in touch within 24hrs. To date - nothing, zero. Online support? Forget it. Always offline. I have now lost three snipe auctions thanks to Gavelthief and now leave it de-activated. In short, thier customer support is **** and I wouldn't give them the steam of my piss and neither should you. Spend your hard earned dollars somewhere else.
Supplier
prestonlanier@gavelthief.com United States
GavelThief
Kudos: 35
Joined: Oct 31, 2008
Re: Gavelthief - Waste of time
18 Jan 2011
Please see this thread: www.webretailer.com/forum/1362...-not-activate-anyone-else-.asp

The original developers have reacquired the GavelThief project and are in the process of getting everything back on track.
Canada Canada
darrell
Kudos: 30
Joined: Feb 25, 2011
Re: Gavelthief - Waste of time
25 Feb 2011
Same problem with me [after I bought the licence]

Just sent another email to you [preston] after having given up ...make it right please ... you have my fee...I have no GT

Darrell
Canada Canada
darrell
Kudos: 30
Joined: Feb 25, 2011
Re: Gavelthief - Waste of time
25 Feb 2011
Preston got back to me right away and I reinstalled GT with my licence # and so far all is well.

Which makes me very happy since I found it to be a great service.

I will keep anyone who is interested posted and share a strange bide-o-matic problem I had in another post [just in case].

Darrell
Canada Canada
darrell
Kudos: 30
Joined: Feb 25, 2011
Re: Gavelthief - Waste of time
7 Mar 2011
Well its a little over a week since it was reinstalled and it worked once, but just now I watched in horror as I lost something I really wanted. I heard the cocked gun sound at 10 seconds then nothing.

All GT reported was "unknown Error".

I'm not sure I trust any of these programs anymore ... I may just go back to manual sniping. That never failed.

Any ideas what might have gone wrong Preston?

World First
Seller Dynamics
ReplyManager
Sellware